PPC Manager: campaigns/filters not accessible in Firefox
Incident Report for Sellics
Resolved
The incident has been resolved and the PPC Manager is fully operational again in Firefox
Posted 3 months ago. Jul 19, 2019 - 12:42 CEST
Identified
Campaigns and filters in the PPC Manager are currently not accessible through Firefox. Please use Chrome as long as the issue persists.
Posted 3 months ago. Jul 19, 2019 - 11:20 CEST
This incident affected: Sellics Vendor Edition (Advertising) and Sellics Seller Edition (PPC Manager).