Increased delay for all inbound support inquires
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted Jun 30, 2020 - 13:28 CEST
Investigating
En/DE
Due to the current situation of COVID-19 and the far reaching implications, Sellics has an increased wait time on all inbound support messages. Rest assured we are trying to focus on our customers in these turbulent times and appreciate your patience in the matter. We have a dedicated COVID-19 webpage aimed at supporting our clients which can be found here: https://sellics.com/updates-amazon-businesses-covid19/

Lieber Sellics user, aufgrund der aktuellen Situation des COVID-19 Weltweit und dessen weitreichenden Auswirkungen hat Sellics eine längere Wartezeit für alle eingehenden Support Nachrichten. Seien Sie versichert, dass wir in diesen schwierigen Zeiten uns auf unsere Kunden konzentrieren und wir bedanken uns schonmal für Ihre Geduld in dieser Angelegenheit.
Wir haben eine spezielle COVID-19-Webseite zur Unterstützung unserer Kunden, die Sie hier finden: https://sellics.com/updates-amazon-businesses-covid19/
Posted Mar 30, 2020 - 12:22 CEST
This incident affected: Sellics Seller Edition (Overall System) and Sellics Vendor Edition (Overall System).