Keyword tool resulting in error 500 for many users
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 12, 2019 - 13:04 CEST
Investigating
We are working on addressing this thank you for the patience.
Posted 3 months ago. Jul 10, 2019 - 11:04 CEST
This incident affected: Sellics Seller Edition (Keyword Rankings).