Understated sales data seen for all advertisers June 4th- June 6th, All Marketplaces.
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted Jul 03, 2020 - 13:11 CEST
Identified
Amazon's API team is reporting an understated level of sales for the period of June 4th-June 6th. This will be seen in the Profit and PPC pages in sellics. We await updates from Amazon's team. Thank you for the patience.
Posted Jun 30, 2020 - 13:32 CEST
This incident affected: Sellics Seller Edition (Sales & Profit, PPC Manager).