Advertising API unstable -> EU data updates missing -> Automation & Ad Scheduling turned off in Europe
Incident Report for Sellics
Resolved
Amazon seems to have resolved the issue and everything is stable again!
Posted 2 months ago. Aug 15, 2019 - 15:16 CEST
Investigating
Amazon's Advertising API is currently having technical issues, preventing us from updating new data and slowing down changes made within Sellics significantly.

We have therefore turned off the automation and ad scheduling for the time being.

Our developers have reached out to Amazon's API team and hope for a speedy solution. Apologies for the inconvenience and thank you for your patience!
Posted 2 months ago. Aug 15, 2019 - 11:06 CEST
This incident affected: Sellics Vendor Edition (Advertising) and Sellics Seller Edition (PPC Manager).