Keyword tool resulting in error 500 for many users
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted Oct 24, 2019 - 15:42 CEST
Investigating
We are working on addressing this. Thank you for the patience.
Posted Oct 23, 2019 - 17:41 CEST
This incident affected: Sellics Seller Edition (Keyword Rankings).