Spy Products & Data currently not visible (Data Migration)
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 19, 2019 - 14:24 CEST
Identified
Due to certain necessary changes in our data structures, the Spy feature currently will not load your data.

This will be resolved later today though. Sorry for any inconvenience caused!
Posted 4 months ago. Jun 19, 2019 - 11:16 CEST
This incident affected: Sellics Seller Edition (Spy).