Increased Support Response Times expected
Incident Report for Sellics
Update
Things are slowly getting back to normal, but we are still not quite there yet - apologies again and thank you for your patience!
Posted Nov 06, 2019 - 10:15 CET
Investigating
There is still an influx of enquiries due to the Profit 2.0 and Keyword Harvesting Rules Betas, while internally some of our team members are inconveniently suffering from illness at this time.

Apologies for any inconvenience and thank you for your patience!

PS. in the meantime, if you haven't already, you may want to check our FAQs on the new Profit and Keyword Rules:

http://help.sellics.com/en/collections/1370595-sales-profit
http://help.sellics.com/en/articles/3215848-how-do-keyword-rules-work
Posted Nov 06, 2019 - 10:14 CET