Maintenance Upgrade for Keyword Ranking feature
Incident Report for SE Status
Resolved
This incident has been resolved.
Posted Dec 13, 2018 - 17:26 CET
Update
We are continuing to work on a fix for this issue.
Posted Dec 12, 2018 - 10:25 CET
Update
We are continuing to work on a fix for this issue.
Posted Dec 12, 2018 - 10:22 CET
Update
We are currently investigating missing rankings and hope to bring them back within 24 hours
Posted Dec 10, 2018 - 10:08 CET
Identified
We are currently updating our keyword ranking database which will lead to quicker navigation and shorter loading times. In the interim, there may be slight delays on new information and longer loading times over the next 24 hours.

As ever, thank you for your patience and sorry for any inconvenience!
Posted Dec 04, 2018 - 17:28 CET
This incident affected: Sellics Seller Edition (Keyword Rankings).