Increased wait times for all customer support inquires
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 04, 2019 - 14:37 CEST
Investigating
Thank you for your patience as we get to all of your questions.
In the interim please consult our FAQ section here: https://intercom.help/sellicsSE/en/
If your question is related to our new profit dashboard, please consult here: https://intercom.help/sellicsSE/en/collections/1370595-sales-profit
Posted about 2 months ago. Aug 21, 2019 - 18:17 CEST
This incident affected: Sellics Seller Edition (Overall System).