Rankings: Rankings missing on "Rankings" tab, but seen on a product level.
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 03, 2019 - 14:28 CEST
Investigating
On the rankings tab, it will appear as if your keywords are no longer ranking. However, on a product level you will be able to see your daily rankings. Our team is investigating the issue.

Apologies and thank you for the patience!
Posted 5 months ago. May 31, 2019 - 11:06 CEST
This incident affected: Sellics Seller Edition (Keyword Rankings).