All historic profit data (outside of the last three days) not seen in cockpit or profit module.
Incident Report for SE Status
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 21:49 CEST
Investigating
Our team is aware of missing profit data
Posted Oct 22, 2019 - 17:44 CEST
This incident affected: Sellics Seller Edition (Cockpit, Sales & Profit).