Ranking section currently not reporting ranking or keyword information
Incident Report for Sellics
Resolved
The cause has been found and fixed.
Posted about 2 months ago. Aug 19, 2019 - 10:55 CEST
Update
We are continuing to investigate this issue.
Posted about 2 months ago. Aug 19, 2019 - 10:54 CEST
Investigating
Thank you for your patience while our team creates a fix.
Posted about 2 months ago. Aug 19, 2019 - 02:42 CEST
This incident affected: Sellics Seller Edition (Keyword Rankings).