PPC Integration not working for EU Seller Centrals
Incident Report for Sellics
Resolved
The issue has been resolved by Amazons team and the PPC integration should now be possible again. If you're still experiencing problems during the integration please reach out to us via chat.
Posted 5 months ago. Jun 03, 2019 - 18:29 CEST
Investigating
It looks like Amazon's Advertising API is having issues collecting new PPC profiles for European (+ Indian) Seller Centrals.

At this time we have no ETA on a fix, but are hopeful that Amazon's API team will be able to, as per usual, get this done within a couple of days.

We will update this status once this is the case. Thank you for your patience!
Posted 5 months ago. Jun 03, 2019 - 18:00 CEST
This incident affected: Sellics Seller Edition (PPC Manager).