Profit 2 currently not accessible for multiple users
Incident Report for SE Status
Resolved
This incident has been resolved.
Posted Dec 17, 2019 - 14:53 CET
Investigating
Some users are also missing recent sales & ppc data in the Profit dashboard.

The root cause for both issues have been found.

We aim to find a solution by tomorrow, probably later today. Apologies for the inconvenience! :/
Posted Dec 17, 2019 - 10:27 CET
This incident affected: Sellics Seller Edition (Sales & Profit).