Niche Analyzer not loading results for certain searches
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted 7 days ago. Oct 09, 2019 - 16:46 CEST
Investigating
There is currently an issue with the niche analyzer. At this point we have no information if it is in relation to a change in Amazon's search results or an issue our end.

Apologies for any inconvenience and thank you for your patience!
Posted 27 days ago. Sep 19, 2019 - 18:09 CEST
This incident affected: Sellics Seller Edition (Niche Analyzer & Product Detector).