Increased wait times for Customer Support inquires and questions
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 06, 2019 - 10:03 CEST
Investigating
We are currently experiencing a high volume of customer questions and inquires. We will answer your question but wait times may be increased. Please consult our our help center in the meantime:
https://intercom.help/sellicsSE/en/
Posted 3 months ago. Jul 29, 2019 - 12:25 CEST
This incident affected: Sellics Seller Edition (Overall System).