PPC Manager / AMS: Unstable Behaviour after recent Updates
Incident Report for SE Status
Resolved
This incident has been resolved.
Posted Feb 08, 2019 - 10:43 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 08, 2019 - 10:42 CET
Identified
There are currently a few issues in the PPC Manager's Optimize feature such as not being able to add (negative) keywords to adgroups. We are looking into this and will resolve them as quickly as possible.

As ever, we are sorry for any inconvenience. On the bright side, we have finished everything on our side with regards to automating Amazon's new targeting campaigns, and are now just waiting for Amazon to resolve certain issues with their new API.
Posted Jan 18, 2019 - 17:45 CET
This incident affected: Sellics Seller Edition (PPC Manager).