PPC integration/Reintegration fails in some cases
Incident Report for SE Status
Resolved
This incident has been resolved.
Posted Sep 23, 2020 - 16:19 CEST
Investigating
In a sparse number of cases, the integration of a PPC advertising account results in a fail. The same case applies for users attemping a reintegration.
Thank you for the patience
Posted Aug 13, 2020 - 15:40 CEST
This incident affected: Sellics Seller Edition (PPC Manager).