Increased Support Response Times expected
Incident Report for SE Status
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 14:57 CET
Update
We are continuing to investigate this issue.
Posted Oct 04, 2019 - 15:00 CEST
Investigating
There is still an influx of enquiries due to the Profit and Keyword Harvesting Rules Betas, while internally some of our team members are inconveniently suffering from illness at this time.

Apologies for any inconvenience and thank you for your patience!

PS. in the meantime, if you haven't already, you may want to check our FAQs on the new Profit and Keyword Rules:

http://help.sellics.com/en/collections/1370595-sales-profit
http://help.sellics.com/en/articles/3215848-how-do-keyword-rules-work
Posted Sep 10, 2019 - 11:06 CEST
This incident affected: Sellics Seller Edition (Other Functionalties / 3rd Party Systems).