Increased wait times for all customer support related inquires
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 18, 2019 - 13:14 CEST
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jun 07, 2019 - 15:45 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 07, 2019 - 15:45 CEST
Investigating
We are currently experiencing a high level of customer support related tickets. We sincerely appreciate your patience. In the interim, please consult our help center and get excited for the -soon to be released- updated profit module! https://intercom.help/sellicsSE
Posted 4 months ago. Jun 07, 2019 - 15:44 CEST